Topologi
Tujuan:
Menghubungkan router antar kantor dengan
menggunakan Tunnel (L2TP/Ipsec)
Blocking Website tertentu dengan
firewall layer7 dan Content
Blokir situs pada jam tertentu
Host yg ada pada R3 dapat mengakses
server di kantor pusat
Materi:
Tunnel (L2TP)
DHCP-Server
Routing static
Default route
NAT
Firewall (Filter Rule, Layer7)
-
Scheduler
-
Script
-
Bridge
Untuk
Konfigurasi awal kita konfig dahulu identity tiap router agar mudah dikenali
Konfigurasi
-
Set Identity pada masing-masing router
[admin@MikroTik] > system
identity set name=R1
[admin@MikroTik] > system
identity set name=R2
[admin@MikroTik] > system
identity set name=R3
|
Konfigurasi
IP Address
[admin@R1] > /ip address
> add address=11.11.11.1/24
comment=INTERNET i interface=ether1
> add address=192.168.20.1/26
comment=LANTAI2 interface=ether3
> add address=192.168.100.1/26
comment=LAN interface=ether2
> add address=192.168.10.1/24
comment=SERVER interface=ether4
|
Konfigurasi
DHCP-Server Router R1
Konfigurasi
DHCP-Server agar pendistribusian IP Address bisa secara otomatis dari router
[admin@R2]
> ip dhcp-server setup
Select
interface to run DHCP server on
dhcp
server interface: ether2
Select
network for DHCP addresses
dhcp
address space: 192.168.100.0/24
Select
gateway for given network
gateway
for dhcp network: 192.168.100.1
Select
pool of ip addresses given out by DHCP server
addresses
to give out: 192.168.100.2-192.168.100.62
Select
DNS servers
dns
servers: 8.8.8.8
Select
lease time
lease
time: 10m
|
Konfigurasi
Default Router & DNS Router R1
Untuk
akses ke internet kita konfigurasi default route
[admin@R1] > ip route add dst-address=0.0.0.0/0
gateway=11.11.11.2
[admin@R1] > ip dns set servers=8.8.8.8
|
Konfigurasi
Static Route
-
Pada
Router R2
[admin@IDN-R2]
> ip route add
dst-address=192.168.200.0/26 gateway=192.168.20.1
|
Konfigurasi
NAT
[admin@R1]
> ip firewall nat add chain=srcnat
out-interface=ether1 action=masquerade
|
Konfigurasi
IP Address
-
Pada
Router R2
[admin@R2]
> /ip address add
> address=192.168.20.2/30 interface=ether1
> address=192.168.20.1/26 interface=ether3
|
Pada
router R2 kita akan menggabungkan host host yg terhubung ke router yg berbeda
interface menjadi 1 segmen
Konfigurasi
Bridge dan ip address Router R2
[admin@R2]
> interface bridge add name=bridge1
disable=no
[admin@R2]
> /interface bridge port
> add interface=ether4 bridge=bridge1
> add interface=ether2 bridge=bridge1
> add interface=ether3 bridge=bridge1
[admin@R2]
> ip address add address=192.168.200.1/26
interface=bridge1
|
Konfigurasi
DHCP-Server Router 3
Konfigurasi
DHCP-Server agar pendistribusian IP Address bisa secara otomatis dari router
[admin@R3]
> ip dhcp-server setup
Select interface to run DHCP server on
dhcp server interface: bridge1
Select network for DHCP addresses
dhcp address space: 192.168.200.0/24
Select gateway for given network
gateway for dhcp network: 192.168.200.1
Select pool of ip addresses given out by DHCP server
addresses to give out: 192.168.200.2-192.168.200.62
Select DNS servers
dns servers: 8.8.8.8
Select lease time
lease time: 10m
|
Konfigurasi
Default Route
Untuk
akses ke internet kita konfigurasi default route
[admin@R2]
> ip route add dst-address=0.0.0.0/0 gateway=192.168.20.1
|
Konfigurasi
L2TP Server pada Router R1
Untuk
konfigurasi awal Tunnel L2TP, kita aktifkan dulu L2TP Server, dengan meng
“enable” opsi pada L2TP Server
[admin@R1] > interface l2tp-server
[admin@R1] > interface l2tp-server server set enabled=yes
use-ipsec=yes ipsec-secret=123
|
Konfigurasi
PPP untuk username & password dialup L2TP
Selanjutnya
kita buat Profile Dial L2TP, profile ini kita gunakan sebagai profile dial
koneksi L2TP dari client, unttuk para meter yg digunakan yaitu:
Username:
coba
Password:
123
Service:
l2tp
Untuk
konfigurasi ip address local address dan remote address, isikan ip address yg
akan digunakan untuk koneksi L2TP.
[admin@R1]
> ppp secret add name=coba password=123 local-address=172.13.56.1
remote-address=172.13.56.2 routes=192.168.30.0/24 service=l2tp
|
Setelah
konfigurasi dari L2TP Server sudah selesai, kita kan membuat dial koneksi dari
L2TP Client agar koneksi L2TP terhubung.
[admin@R3]
> interface l2tp-client
/add connect-to=11.11.11.1 disabled=no mrru=1600
name=l2tp-client password=123 user=coba
|
Tambahkan
static route untuk menuju network server
[admin@R3] > ip route add dst-address=192.168.10.0/24
gateway=l2tp-client
|
Pengujian
Cek
apakah koneksi L2TP client sudah connected belum pada sisi router R3 dengan
cara Ping Menuju IP address server di router R1
Konfigurasi Scheduler & Blocking
website pada jam tertentu
Sebelum konfigurasi scheduler &
blocking kita konfigurasi dulu clock yg ada pada router, pada clock kita akan
mengaju pada konfigurasi NTP agar antara clock router dan waktu setempat bisa
sesuai
Konfigurasi NTP
[admin@R1] > system ntp client set enable=yes primary-ntp=111.92.175.248
secondary-ntp=130.54.208.201 mode=unicast
[admin@R1] > system ntp client print
enabled:
yes
mode:
unicast
primary-ntp:
111.92.175.248
secondary-ntp:
130.54.208.201
dynamic-servers:
status:
started
|
Konfigurasi Clock
[admin@R1]
> system clock set
time-zone-name=Asia/Jakarta
[admin@R1]
> system clock print
time:
23:57:43
date:
aug/28/2016
time-zone-autodetect:
yes
time-zone-name:
Asia/Jakarta
gmt-offset:
+07:00
dst-active:
no
|
Pada
Konfigurasi Scheduler kita akan melakukan blocking website tertentu dengan
parameter waktu. Website yg akan kita blok adalah facebook (www.facebook.com). Disini kita
akan mengkonfigurasi firewall filter terlebuh dahulu
[admin@R1]
> ip firewall filter add chain=forward
content=facebook action=drop protocol=tcp comment=block-fb-http
|
Karena
facebook juga menggunakan protocol SSL (443), maka kita juga akan memblok
protocol web tersebut
[admin@R1]
> ip firewall layer7-protocol add
name=facebook regexp=^.+(facebook.com).*$
[admin@R1]
> ip firewall filter add chain=forward
comment=block-fb-https layer7-protocol=facebook dst-port=443 protocol=tcp
action=drop
|
Pada
konfigurasi scheduler kita akan menjadwal bahwa website tersebut akan diblok
pada jam tertentu dan akan aktif pada jam tertentu pula
Jadwal
Blok FB: Jam 08:00 Pagi
Jadwal
Aktif FB: Jam 17:00 Sore
Berikut
script konfigurasi yang akan mengijinkan https dan http facebook
[admin@R1]
> /system script
> add name=”fb-allow-https” policy=write,read,policy,test,sniff
source={/ip firewall filter set disabled=yes [/ip firewall filter find
content=”block-fb-https”]}
> add name=”fb-allow-http”
policy=write,read,policy,test,sniff source={/ip firewall filter set
disabled=yes [/ip firewall filter find content=”block-fb-http”]}
|
Dan
ini adalah konfigurasi script yang tidak mengijinkan facebook
[admin@R1]
> /system script
> add name=”fb-deny-http”
policy=write,read,policy,test,sniff source={/ip firewall filter set
disabled=no [/ip firewall filter find content=”block-fb-http”]}
> add name=”fb-deny-https” policy=write,read,policy,test,sniff
source={/ip firewall filter set disabled=no [/ip firewall filter find
content=”block-fb-https”]}
|
Tambahkan
jadwal akan memblok facebook mulai dari jam 8 pagi
[admin@R1]
> system scheduler
> add name=fb-http-deny start-time=08:00:00
start-date=aug/27/2016 interval=1d on-event=fb-deny-http
> add name=fb-https-deny start-time=08:00:00
start-date=aug/27/2016 interval=1d on-event=fb-deny-https
|
Jangan
lupa tambahkan jadwal yang akan mengijinkan facebook dari jam 5 sore
[admin@R1]
> /system scheduler
> add name=fb-https-allow start-time=17:00:00
start-date=aug/27/2016 interval=1d on-event=fb-allow-https
> add name=fb-http-allow start-time=17:00:00
start-date=aug/27/2016 interval=1d on-event=fb-allow-http
|
Pengujian
Akses
Website (facebook.com) diatas jam 08.00 pagi
Akses
Website selain facebook diatas jam 08.00 pagi
1 komentar:
Write komentarKok kayak ada beberapa bagian yang ilang ya gan konfigurasi nya ....
ReplyEmoticonEmoticon